<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
  <head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title>Life remembered: ‘Coach Cool Breeze Jones’ known for his calm demeanor | Rantoul Press</title>
    <meta http-equiv="content-language" content="en" />
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script>
<script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
<link rel="image_src" href="http://www.rantoulpress.com/sites/all/files/imagecache/300x300_width_height_scale/images/2017/07/11/542154_0531-spor-boys-state-track4.jpg" />
<link rel="shortcut icon" href="http://www.rantoulpress.com/sites/all/files/favicon.ico" type="image/x-icon" />
<meta name="keywords" content="Champaign,Urbana,Danville,Paxton,Rantoul,Mahomet,Monticello,Tuscola,East Central Illinois,University of Illinois at Urbana-Champaign,News" />
<meta name="copyright" content="Copyright (c) 2015 The News-Gazette, Inc." />
<meta name="description" content="Mykhail Chambers normally keeps a calm disposition, but after clearing 6 feet, 8 inches to win the 2008 IHSA Class AA state title in the high jump as a senior for Urbana, he exploded with emotion." />
    <link type="text/css" rel="stylesheet" media="all" href="http://www.rantoulpress.com/sites/all/modules/custom/custom_node/custom_node.css?b" />
<link type="text/css" rel="stylesheet" media="all" href="http://www.rantoulpress.com/sites/all/modules/custom/custom_blocks/custom_blocks.css?b" />
<link type="text/css" rel="stylesheet" media="all" href="http://www.rantoulpress.com/sites/all/files/css/css_190ec8b916b82af93dac89350e9e7c1e.css" />
<link type="text/css" rel="stylesheet" media="screen,projection" href="http://www.rantoulpress.com/sites/all/files/css/css_f41e3a9a17e582f969cc3acacae59e07.css" />
<link type="text/css" rel="stylesheet" media="print" href="http://www.rantoulpress.com/sites/all/files/css/css_3c136f75d73d1ca051f2c1f53c5e866f.css" />
<!--[if lte IE 7]>
        <link type="text/css" rel="stylesheet" href="/sites/all/modules/custom/ng_weather/css/weather_ie7.css" media="all" />
      <![endif]-->        <script type="text/javascript" src="http://www.rantoulpress.com/sites/all/files/js/js_6f96ecf9d5c836298067149e25f504f4.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","googleanalytics":{"trackOutgoing":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls|xml|z|zip"},"uc_ajax_cart":{"CALLBACK":"\/uc_ajax_cart\/add\/item","SHOW_CALLBACK":"\/uc_ajax_cart\/show","CART_LINK_CALLBACK":"\/uc_ajax_cart\/addlink","BLOCK_UI":2,"TIMEOUT":2500,"UPDATE_CALLBACK":"\/uc_ajax_cart\/update","UPDATE":0,"CART_VIEW_ON":0,"SHOW_VIEW_CALLBACK":"\/uc_ajax_cart\/show-cart-view","TRACK_CLOSED_STATE":0,"INITIAL_CLOSED_STATE":0,"CART_PANE_EFFECT":0,"CART_PANE_EFFECT_DURATION":200,"HIDE_CART_OPERATIONS":false,"COLLAPSIBLE_CART":0,"CART_OPERATION":"Cart","ADD_TITLE":"Please wait","ADD_MESSAGES":["Adding product to cart..."],"REMOVE_TITLE":"Please wait","REMOVE_MESSAGES":["Removing product from cart..."],"UPDATE_TITLE":"Please wait","UPDATE_MESSAGES":["Updating cart..."]},"ws_fl":{"width":92,"height":"21"},"ws_gpo":{"type":"medium","counter":true},"jPlayer":{"swfPath":"\/sites\/all\/libraries\/jplayer","autoPlay":0}});
//--><!]]>
</script>
    
    <!--this code applies superfish style to the network, network lower, and user options menus-->
    <script type="text/javascript">
      $(document).ready(function() {
        $("#network-menu ul.menu").superfish();
        $("#network-menu-lower ul.menu").superfish();
        $("#user-account ul.menu").superfish();
      });
    </script>
  </head>

  <body id="body-specs">
    <div id="wrapper">
      <div class="nav-bar-wrapper">
       <div id="network-nav-bar">
                    <div id="network-menu">
                          <div id="block-menu-menu-ng-network" class="block block-menu region-odd odd region-count-1 count-1">

  
  <div class="content"><ul class="menu"><li class="expanded first last"><a href="/" title="Our sites">Our Sites</a><ul class="menu"><li class="expanded first"><a href="http://www.news-gazette.com" title="">The News-Gazette</a><ul class="menu"><li class="leaf first"><a href="http://digital.news-gazette.com" title="Digital Services">Digital Services</a></li>
<li class="leaf last"><a href="http://www.news-gazette.com/eedition" title="eEdition">eEdition</a></li>
</ul></li>
<li class="leaf"><a href="http://www.news-gazette.com/sports/illini-sports" title="">IlliniHQ</a></li>
<li class="leaf"><a href="http://www.wdws.com/" title="">NewsTalk 1400 WDWS-AM</a></li>
<li class="leaf"><a href="http://www.whms.com/" title="">Lite Rock 97.5 WHMS</a></li>
<li class="leaf"><a href="http://www.1079wkio.com" title="">107.9 WKIO</a></li>
<li class="expanded"><a href="http://www.news-gazette.com/news-gazette-community-newspapers.html" title="Community News">Community News</a><ul class="menu"><li class="leaf first"><a href="http://www.county-star.com/" title="">County Star</a></li>
<li class="leaf"><a href="http://www.the-independent-news.com/" title="">The Independent News</a></li>
<li class="leaf"><a href="http://www.leaderlandnews.com/" title="">The Leader</a></li>
<li class="leaf"><a href="http://www.leroyfcpress.com/" title="">LeRoy Farmer City Press</a></li>
<li class="leaf"><a href="http://www.mcitizen.com/" title="">Mahomet Citizen</a></li>
<li class="leaf"><a href="http://www.paxtonrecord.net/" title="">Paxton Record</a></li>
<li class="leaf"><a href="http://www.journal-republican.com/" title="">Piatt County Journal-Republican</a></li>
<li class="leaf last"><a href="http://www.rantoulpress.com/" title="">Rantoul Press</a></li>
</ul></li>
<li class="expanded last"><a href="http://www.news-gazette.com/news-gazette-magazines.html" title="">Magazines</a><ul class="menu"><li class="leaf first"><a href="http://www.athomeillinois.com" title="At Home ">At Home </a></li>
<li class="leaf last"><a href="http://www.centralillinoisbusiness.com/" title="">Central Illinois Business</a></li>
</ul></li>
</ul></li>
</ul></div>
  
</div>
           </div><!--close network_menu-->
         
         
         <div id="network-login-area">
                        <div id="nav-bar-text">
                   <ul>
                       <li><a href="/user/login?destination=sports/misc/2017-07-11/life-remembered-%E2%80%98coach-cool-breeze-jones%E2%80%99-known-his-calm-demeanor.html">LOGIN</a></li>
                       <li><a href="/user/register" title="Create new account.">Create new account</a></li>
					   <li><a href="/user/password" title="Request new password via e-mail.">Login problems?</a></li>
                   </ul>
             </div><!--closes create account-->         </div><!--/network-login-area-->
         
                  
                  
         <div id="header-search-field">
                        <form action="/sports/misc/2017-07-11/life-remembered-%E2%80%98coach-cool-breeze-jones%E2%80%99-known-his-calm-demeanor.html"  accept-charset="UTF-8" method="post" id="search-theme-form">
<div><div id="search" class="container-inline">
  <div class="form-item" id="edit-search-theme-form-1-wrapper">
 <label for="edit-search-theme-form-1">Search: </label>
 <input type="text" maxlength="128" name="search_theme_form" id="edit-search-theme-form-1" size="15" value="" class="form-text search-theme-form-text-input" />
</div>
<input type="image" name="" value="Search" id=""  class="form-submit" src="http://www.rantoulpress.com/sites/all/modules/custom/search_content/images/mag_glass.gif" alt="Click to search" title="Click to search" />
<a href="#" onclick="return false;"><img class="search-options-arrow" src="/sites/all/modules/custom/search_content/images/down_arrows.gif" /></a><div class="search-options-dropdown"><label>Search in:</label> <div class="form-item" id="edit-content-type-wrapper">
 <select name="content-type" class="form-select" id="edit-content-type" ><option value="" selected="selected">Everything</option></select>
</div>
</div><input type="hidden" name="form_build_id" id="form-10db44863e5489d4e28a21c820e0e99a" value="form-10db44863e5489d4e28a21c820e0e99a"  />
<input type="hidden" name="form_id" id="edit-search-theme-form" value="search_theme_form"  />
</div>

</div></form>
                    </div><!--closes header search field-->
        </div><!--closes nav-bar-->
      </div><!--/nav-bar-wrapper-->
      
      <div id="header"> <!--includes logo and menu-->
        <div id="main-logo">
          <div id="business_directory_search">
                      </div>
          <a href = "/"><img src="http://www.rantoulpress.com/sites/all/themes/custom/cms_desktop/rp_desktop/images/rp_logo.gif" alt = "The Rantoul Press"  /></a>
          <a href = "/"><img id="cn-logo" src="http://www.rantoulpress.com/sites/all/themes/custom/cms_desktop/rp_desktop/images/cn_logo.gif" alt = "The News-Gazette Comunity Newspapers" /></a>
        </div><!--/main-logo--> 
        <div id="site-slogan">
             
        </div>
      </div> <!--closes header-->   
 
      <div class="container">
        <div class="span-24">
          <div id="menu">
                          <!-- Primary || Superfish -->
              <div id="superfish">
                <div id="superfish-inner">
                  <ul class="menu"><li class="leaf first"><a href="/category/news" title="News">News</a></li>
<li class="leaf"><a href="/category/sports" title="Sports">Sports</a></li>
<li class="leaf"><a href="/obituaries" title="Obituaries">Obituaries</a></li>
<li class="leaf"><a href="/category/opinions" title="Opinions">Opinions</a></li>
<li class="expanded"><a href="/classified" title="Classified Ads">Classified Ads</a><ul class="menu"><li class="leaf first last"><a href="/rantoul/fakead" title="">Fake Ad Contest Rules</a></li>
</ul></li>
<li class="leaf"><a href="/multimedia/photogallery" title="">Media</a></li>
<li class="leaf"><a href="/subscribe-rantoul-press.html" title="Subscription Information">Subscribe</a></li>
<li class="leaf"><a href="/rantoul-forms.html" title="Announcement Forms">Forms</a></li>
<li class="leaf"><a href="/calendar" title="Upcoming Events">Events</a></li>
<li class="expanded last"><a href="/contact" title="Contact Us">Contact</a><ul class="menu"><li class="leaf first"><a href="/rantoul-feedback.html" title="Feedback Form">Feedback Form</a></li>
<li class="leaf last"><a href="/contact" title="Contact Us">Contact Us</a></li>
</ul></li>
</ul>                </div><!-- / inner -->
              </div><!-- /primary || superfish -->
                      </div><!--closes menu bar-->
                  </div><!--closes header-->
        
        <div id="content-wrapper" class="span-24"><!--holds center and right col divs together-->
          <!--col class changed to span-16-plus, was span-15, DD-->
          <div id="main-content" 
            class="span-16-plus">
            <div class="breadcrumb"><a href="/">Home</a> » <a href="/category/sports">Sports</a> » <a href="/category/sports/prep-sports">Prep Sports</a> » <a href="/category/sports/prep-sports/track-and-field">Track and Field</a></div><h2>Life remembered: ‘Coach Cool Breeze Jones’ known for his calm demeanor</h2>           
                          
  <div id="node-1546732" class="node">
     
        
    
  <span class="submitted"><div class="submitted"><span class="timestamp">Tue, 07/11/2017 - 12:10pm</span> | <span class="authors"><a href="/author/anthony-zilis">Anthony Zilis</a></span></div></span>
  
      <div class="related-content">
        <div id="related-content-media">
    

      
          <a href="http://www.rantoulpress.com/sites/all/files/imagecache/lightbox_800_600_scale/images/2017/07/11/542154_0531-spor-boys-state-track4.jpg" class="imagefield imagefield-jquery-lightbox imagefield-jquery-lightbox-300_width_scale" rel="lightbox" title="Harbert Jones passed away on June 29 at the age of 73. Jones, nicknamed “Coach Cool Breeze Jones” was always known for his calm demeanor. (&lt;a href=&quot;/image/2017-07-11/harbert-jones-1.html&quot;&gt;More&lt;/a&gt;)"><img src="http://www.rantoulpress.com/sites/all/files/imagecache/300_width_scale/images/2017/07/11/542154_0531-spor-boys-state-track4.jpg" alt="Harbert Jones 1" title="Harbert Jones 1"  class="imagecache imagecache-300_width_scale" width="300" height="195" /></a>   
  
              <div><small><strong>Photo by: Heather Coit/The News-Gazette</strong></small></div>
            <div id="related-content-caption"><small>Harbert Jones passed away on June 29 at the age of 73. Jones, nicknamed “Coach Cool Breeze Jones” was always known for his calm demeanor.</small></div>        
      
  	

      <ul id="related-content-slider" class="col-md-12 well">
                <li>
    
      <div class="related-media-type">
      Image    </div>
    <a href="http://www.rantoulpress.com/sites/all/files/imagecache/lightbox_800_600_scale/images/2017/07/11/623804_0829-spor-rantoul-harbert-j.jpg" class="imagefield imagefield-jquery-lightbox imagefield-jquery-lightbox-150_width_scale" rel="lightbox" title="Harbert Jones passed away on June 29 at the age of 73. Jones, nicknamed “Coach Cool Breeze Jones” was always known for his calm demeanor. (&lt;a href=&quot;/image/2017-07-11/harbert-jones-2.html&quot;&gt;More&lt;/a&gt;)"><img src="http://www.rantoulpress.com/sites/all/files/imagecache/150_width_scale/images/2017/07/11/623804_0829-spor-rantoul-harbert-j.jpg" alt="Harbert Jones 2" title="Harbert Jones 2"  class="imagecache imagecache-150_width_scale" width="104" height="150" /></a> 
   
  
  
        </li>
  	

    </ul>
<!--  -->  </div>
                        </div>
    
      <div id="social-media-widgets">
      <a href="http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.rantoulpress.com%2Fsports%2Fmisc%2F2017-07-11%2Flife-remembered-%25E2%2580%2598coach-cool-breeze-jones%25E2%2580%2599-known-his-calm-demeanor.html&amp;layout=button_count&amp;show_faces=false&amp;action=like&amp;colorscheme=light&amp;width=92&amp;height=21&amp;font=&amp;locale=" title="I Like it" class="service-links-facebook-like" rel="nofollow"><span style="display:none;">Facebook Like</span></a><a href="http://www.rantoulpress.com/sports/misc/2017-07-11/life-remembered-%E2%80%98coach-cool-breeze-jones%E2%80%99-known-his-calm-demeanor.html" title="Plus it" class="service-links-google-plus-one" rel="nofollow"><span style="display:none;">Google Plus One</span></a><a href="http://twitter.com/share?url=http%3A%2F%2Fwww.rantoulpress.com%2Fsports%2Fmisc%2F2017-07-11%2Flife-remembered-%25E2%2580%2598coach-cool-breeze-jones%25E2%2580%2599-known-his-calm-demeanor.html&amp;count=horizontal&amp;via=&amp;text=Life%20remembered%3A%20%E2%80%98Coach%20Cool%20Breeze%20Jones%E2%80%99%20known%20for%20his%20calm%20demeanor&amp;counturl=http%3A%2F%2Fwww.rantoulpress.com%2Fsports%2Fmisc%2F2017-07-11%2Flife-remembered-%25E2%2580%2598coach-cool-breeze-jones%25E2%2580%2599-known-his-calm-demeanor.html" class="twitter-share-button service-links-twitter-widget" title="Tweet This" rel="nofollow"><span style="display:none;">Tweet Widget</span></a>    </div>
    
  <div class="content">
    <p>Mykhail Chambers normally keeps a calm disposition, but after clearing 6 feet, 8 inches to win the 2008 IHSA Class AA state title in the high jump as a senior for Urbana, he exploded with emotion.</p>
<p>When he looked over at Harbert Jones standing behind the fence at O’Brien Stadium on the campus of Eastern Illinois University, the man nicknamed “Coach Cool Breeze” was predictably calm, standing still with a smile on his face and sunglasses over his eyes. Chambers, though, didn’t mistake his coach’s laid back vibe for disinterest.</p>
<p>“We talked about it afterwards and he said, ‘I knew it all along, I knew it was going to happen,’” said Chambers, who went on to jump for Georgia Tech. “He was kind of just like Yoda over there on the sidelines, just very calm and reserved. He gave me a handshake and a hug, and we posed for some pictures afterward. It was completely what you expected.”</p>
<p>Jones, who passed away last Thursday at 73, cared about his athletes. Chambers had the hardware to prove it — beyond his state championship medal.</p>
<p>Jones, an art teacher, made Chambers a meticulous sculpture made of paper mache and clay of Chambers jumping over the bar in a Georgia Tech uniform for a birthday gift.</p>
<p>A year later, Jones retired after 17 years of coaching at Urbana before becoming a head coach at Rantoul and eventually an assistant at St. Thomas More. He was still enthusiastic up until his final days.</p>
<p>“I just talked to him the other day. We were talking about summer track,” St. Thomas More coach Dave Behm said. “He was just a wise man. Great to coach with ... He was very observant with his athletes about what they were doing and corrected them in a way that they got involved and they learned about the sport itself and becoming better.”</p>
<p>Jones served in the Air Force for 26 years, finishing with 14 at Chanute Air Force Base in Rantoul. While he kept up his military condition — Chambers remembers him reeling off 30 pullups and making it look easy — his coaching style was never militaristic. Rather than yell at athletes who misbehaved, he would calmly ask them to leave.</p>
<p>“He never was a screamer or a yeller at the kids,” said Mitch Wilson, Rantoul’s boys’ track and field coach who ran for Jones during the summer club season and also coached with him. “He was very even-keeled and calm and just explained things.”</p>
<p>Chambers remembers Jones soaking up new information along with him, offering new ideas to transform him into a state championship high jumper. He introduced him to plyometrics, used elastic bands to improve his explosiveness and borrowed the basketball team’s Vertimax, a machine that improves vertical leap.</p>
<p>But he didn’t only care about his star athletes.</p>
<p>“If someone needed a ride to practice one day, he would offer to drive the athlete himself or he would arrange for a carpool,” Chambers said. “He would set up study sessions. He would talk to athletes that were strong in some academics and those that weren’t to see if they could pair up. He did just a lot of things to make sure everyone could have the best overall experience.”</p>
<p>He never let his emotions, though, get in the way of his level head. One year in summer track, Chambers was initially denied a trip to the national championships in the triple jump based on a scoring error. Chambers said it was one of the few times he truly exploded in anger.</p>
<p>Jones was equally mad. But he kept calm and went up to the press box to vouch for his athlete.</p>
<p>“I remember him going up to the press box,” “I was looking up at him in the press box and I expected to see him going off because he was just as mad as I was. But it just looked like he was talking very professionally. He came back and said, ‘They’re going to let you go through’ ... He made sure that my hard work and effort were noticed.”</p>
<p><strong><em>sports@rantoulpress.com</em></strong></p>
<div class="clear"></div>  </div>
      <div class="links">
      <ul class="links inline"><li class="comment_forbidden first"><span><a href="/user/login?destination=comment%2Freply%2F1546732%23comment-form">Login</a> or <a href="/user/register?destination=comment%2Freply%2F1546732%23comment-form">register</a> to post comments</span></li>
<li class="print_html"><a href="/print/1546732" title="Display a printer-friendly version of this page." class="print-page" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/print/icons/print_icon.gif" alt="Printer-friendly version" title="Printer-friendly version" width="16" height="16" class="print-icon" /></a></li>
<li class="print_mail"><a href="/printmail/1546732" title="Send this page by email." class="print-mail" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/print/icons/mail_icon.gif" alt="Send by email" title="Send by email" width="16" height="16" class="print-icon" /></a></li>
<li class="service-links-facebook"><a href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.rantoulpress.com%2Fsports%2Fmisc%2F2017-07-11%2Flife-remembered-%25E2%2580%2598coach-cool-breeze-jones%25E2%2580%2599-known-his-calm-demeanor.html&amp;t=Life+remembered%3A+%E2%80%98Coach+Cool+Breeze+Jones%E2%80%99+known+for+his+calm+demeanor" title="Share on Facebook." class="service-links-facebook" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/service_links/images/facebook.png" alt="Facebook" title="" width="16" height="16" /></a></li>
<li class="service-links-twitter"><a href="http://twitter.com/share?url=http%3A%2F%2Fwww.rantoulpress.com%2Fsports%2Fmisc%2F2017-07-11%2Flife-remembered-%25E2%2580%2598coach-cool-breeze-jones%25E2%2580%2599-known-his-calm-demeanor.html&amp;text=Life%20remembered%3A%20%E2%80%98Coach%20Cool%20Breeze%20Jones%E2%80%99%20known%20for%20his%20calm%20demeanor" title="Share this on Twitter" class="service-links-twitter" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/service_links/images/twitter.png" alt="Twitter" title="" width="16" height="16" /></a></li>
<li class="service-links-google"><a href="http://www.google.com/bookmarks/mark?op=add&amp;bkmk=http%3A%2F%2Fwww.rantoulpress.com%2Fsports%2Fmisc%2F2017-07-11%2Flife-remembered-%25E2%2580%2598coach-cool-breeze-jones%25E2%2580%2599-known-his-calm-demeanor.html&amp;title=Life+remembered%3A+%E2%80%98Coach+Cool+Breeze+Jones%E2%80%99+known+for+his+calm+demeanor" title="Bookmark this post on Google." class="service-links-google" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/service_links/images/google.png" alt="Google" title="" width="16" height="16" /></a></li>
<li class="service-links-yahoo"><a href="http://bookmarks.yahoo.com/myresults/bookmarklet?u=http%3A%2F%2Fwww.rantoulpress.com%2Fsports%2Fmisc%2F2017-07-11%2Flife-remembered-%25E2%2580%2598coach-cool-breeze-jones%25E2%2580%2599-known-his-calm-demeanor.html&amp;t=Life+remembered%3A+%E2%80%98Coach+Cool+Breeze+Jones%E2%80%99+known+for+his+calm+demeanor" title="Bookmark this post on Yahoo." class="service-links-yahoo" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/service_links/images/yahoo.png" alt="Yahoo" title="" width="16" height="16" /></a></li>
<li class="service-links-stumbleupon"><a href="http://www.stumbleupon.com/submit?url=http%3A%2F%2Fwww.rantoulpress.com%2Fsports%2Fmisc%2F2017-07-11%2Flife-remembered-%25E2%2580%2598coach-cool-breeze-jones%25E2%2580%2599-known-his-calm-demeanor.html&amp;title=Life+remembered%3A+%E2%80%98Coach+Cool+Breeze+Jones%E2%80%99+known+for+his+calm+demeanor" title="Thumb this up at StumbleUpon" class="service-links-stumbleupon" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/service_links/images/stumbleit.png" alt="StumbleUpon" title="" width="16" height="16" /></a></li>
<li class="service-links-reddit"><a href="http://reddit.com/submit?url=http%3A%2F%2Fwww.rantoulpress.com%2Fsports%2Fmisc%2F2017-07-11%2Flife-remembered-%25E2%2580%2598coach-cool-breeze-jones%25E2%2580%2599-known-his-calm-demeanor.html&amp;title=Life+remembered%3A+%E2%80%98Coach+Cool+Breeze+Jones%E2%80%99+known+for+his+calm+demeanor" title="Submit this post on reddit.com." class="service-links-reddit" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/service_links/images/reddit.png" alt="Reddit" title="" width="16" height="16" /></a></li>
<li class="service-links-digg"><a href="http://digg.com/submit?phase=2&amp;url=http%3A%2F%2Fwww.rantoulpress.com%2Fsports%2Fmisc%2F2017-07-11%2Flife-remembered-%25E2%2580%2598coach-cool-breeze-jones%25E2%2580%2599-known-his-calm-demeanor.html&amp;title=Life+remembered%3A+%E2%80%98Coach+Cool+Breeze+Jones%E2%80%99+known+for+his+calm+demeanor" title="Digg this post on digg.com" class="service-links-digg" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/service_links/images/digg.png" alt="Digg" title="" width="16" height="16" /></a></li>
<li class="service-links-delicious last"><a href="http://del.icio.us/post?url=http%3A%2F%2Fwww.rantoulpress.com%2Fsports%2Fmisc%2F2017-07-11%2Flife-remembered-%25E2%2580%2598coach-cool-breeze-jones%25E2%2580%2599-known-his-calm-demeanor.html&amp;title=Life+remembered%3A+%E2%80%98Coach+Cool+Breeze+Jones%E2%80%99+known+for+his+calm+demeanor" title="Bookmark this post on del.icio.us." class="service-links-delicious" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/service_links/images/delicious.png" alt="del.icio.us" title="" width="16" height="16" /></a></li>
</ul>    </div>
    <div class="meta">
          <div id="vocab-1546732-1-wrapper" class="vocab-wrapper"><span class="vocab-label">Categories (5):</span><span class="vocab-terms"><a href="/category/sports/prep-sports">Prep Sports</a>, <a href="/category/sports/misc">Misc.</a>, <a href="/category/sports/prep-sports/track-and-field">Track and Field</a>, <a href="/category/sports/prep-sports/miscellaneous">Miscellaneous</a>, <a href="/category/sports">Sports</a></span></div>      </div>
      <div id="comment-info-wrapper">
      <h3>Comments</h3>
      <p><em>Rantoul Press embraces discussion of both community and world issues. We welcome you to contribute your ideas, opinions and comments, but we ask that you avoid personal attacks, vulgarity and hate speech. we reserve the right to remove any comment at its discretion, and we will block repeat offenders' accounts. To post comments, you must first be a registered user, and your username will appear with any comment you post. Happy posting.</em></p>
    </div>
          <p><a href="/user/login?destination=comment/reply/1546732#comment-form">Login</a> or <a href="/user/register?destination=comment/reply/1546732#comment-form">register</a> to post comments</p>
        </div>
                      </div><!--closes main-content-->
          
          <div id="right-column" class="span-8-minus last">
              <div id="block-custom_blocks-0" class="block block-custom_blocks region-odd even region-count-1 count-6">

  
  <div class="content"><div id ="custom-blocks-dotd">
  <a href="http://www.news-gazette.com/store/deal-day" id="header-link" title="Deal of the Day" target="_blank"></a>  <h4><a href="http://www.news-gazette.com/store/deal-day/restaurants/humble-hog-10-5.html" target="_blank">Humble Hog</a></h4>
  <div><a href="http://www.news-gazette.com/store/deal-day/restaurants/humble-hog-10-5.html" target="_blank">Buy a $10.00 certificate for only $5.00</a></div>
  <div id="stock-warning"></div>
  <div id="business-logo"><a href="http://www.news-gazette.com/store/deal-day/restaurants/humble-hog-10-5.html" title="Humble Hog" target="_blank"><img src="http://www.rantoulpress.com/sites/all/files/imagecache/200x125_width_height_scale/businesses/logos/hh_logo1.png" alt="Logo for " title="Logo for "  class="imagecache imagecache-200x125_width_height_scale" width="105" height="68" /></a></div>
  <div class="custom-blocks-dotd-more">
        <ul>
          </ul>
    <!--<div class="center"><small>()</small></div>-->
    <!--<h5></h5>-->
    <!--<ul>
      <li></li>
      <li></li>
    </ul>-->
  </div>
</div></div>
  
</div>
<div id="block-block-6" class="block block-block region-even odd region-count-2 count-7">

  
  <div class="content"><!-- /4073248/Weeklies_Featured_MR_ROS --><!-- /4073248/Weeklies_Featured_MR_ROS --><div id='div-gpt-ad-1479763295532-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1479763295532-0'); });
</script></div>
<!-- Rantoul_Press_RunofSite_MR --><!-- Rantoul_Press_RunofSite_MR --><div id='div-gpt-ad-1391718641158-0' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1391718641158-0'); });
</script></div>
</div>
  
</div>
          </div>   
        </div><!--closes content-wrapper-->
        <div id="feeder">
                  </div>
      </div><!--closes container-->
    </div><!-- closes wrapper -->
    
    <div class="nav-bar-wrapper">
      <div id="network-nav-bar-lower">
                  <div id="network-menu-lower">
                        <div id="block-menu-menu-menu-network-menu-lower" class="block block-menu region-odd even region-count-1 count-4">

  
  <div class="content"><ul class="menu"><li class="expanded first last"><a href="/" title="Our Sites">Our Sites</a><ul class="menu"><li class="expanded first"><a href="http://www.news-gazette.com/" title="News-Gazette">News-Gazette</a><ul class="menu"><li class="leaf first"><a href="http://digital.news-gazette.com/" title="Digital Services">Digital Services</a></li>
<li class="leaf last"><a href="http://www.news-gazette.com/eedition" title="e-Edition">e-Edition</a></li>
</ul></li>
<li class="leaf"><a href="http://www.illinihq.com" title="IlliniHQ.com">IlliniHQ</a></li>
<li class="leaf"><a href="http://www.wdws.com" title="NewsTalk 1400 WDWS-AM">NewsTalk 1400 WDWS-AM</a></li>
<li class="leaf"><a href="http://www.whms.com" title="Lite Rock 97.5 WHMS">Lite Rock 97.5 WHMS</a></li>
<li class="leaf"><a href="http://www.1079wkio.com" title="">107.9 WKIO</a></li>
<li class="expanded"><a href="http://www.news-gazette.com/news-gazette-community-newspapers.html" title="Community News">Community News</a><ul class="menu"><li class="leaf first"><a href="http://www.county-star.com" title="County Star">County Star</a></li>
<li class="leaf"><a href="http://www.the-independent-news.com" title="Independent News">Independent News</a></li>
<li class="leaf"><a href="http://www.leaderlandnews.com" title="The Leader">The Leader</a></li>
<li class="leaf"><a href="http://www.leroyfcpress.com/" title="">LeRoy Farmer City Press</a></li>
<li class="leaf"><a href="http://www.mcitizen.com" title="Mahomet Citizen">Mahomet Citizen</a></li>
<li class="leaf"><a href="http://www.paxtonrecord.net" title="Paxton Record">Paxton Record</a></li>
<li class="leaf"><a href="http://www.journal-republican.com" title="Piatt County Journal-Republican">Piatt County Journal-Republican</a></li>
<li class="leaf last"><a href="http://www.rantoulpress.com" title="Rantoul Press">Rantoul Press</a></li>
</ul></li>
<li class="expanded last"><a href="http://www.news-gazette.com/news-gazette-magazines.html" title="Magazines">Magazines</a><ul class="menu"><li class="leaf first"><a href="http://www.athomeillinois.com" title="At Home">At Home </a></li>
<li class="leaf last"><a href="http://www.centralillinoisbusiness.com" title="Central Illinois Business">Central Illinois Business</a></li>
</ul></li>
</ul></li>
</ul></div>
  
</div>
          </div><!--close network_menu-lower-->
                
              </div><!--closes nav-bar-->
    </div><!--/nav-bar-wrapper-->
    
    <div id="footer-area">
              <div id="footer" class="clear">
                      <div id="block-block-16" class="block block-block region-odd odd region-count-1 count-5">

  
  <div class="content"><div class="span-24">Contents of this site are <a href="/section/services/reader-services/copyright.html">Copyright © 2015 Rantoul Press</a>. All rights reserved.<br /><a href="/sitemap/">Sitemap</a> | <a href="/section/services/online-services/news-gazette-online-privacy-policy.html">Privacy Policy</a> | <a href="/section/services/online-services/terms-use.html">Terms of Use</a> | <a href="/contact/">Contact Us</a> | <a href="/our-clients">Our Clients</a></div>
<div class="span-24"><a href="http://digital.news-gazette.com/web-design-development" target="_blank"><img alt=" Web Design/Development Champaign-Urbana" src="/sites/all/themes/custom/cms_960_desktop/images/digital_services_logo.png" /></a></div>
</div>
  
</div>
                            </div>
          </div><!--closes footer area-->
    <script type="text/javascript">
<!--//--><![CDATA[//><!--
var _gaq = _gaq || [];_gaq.push(["_setAccount", "UA-4954131-30"]);_gaq.push(["_trackPageview"]);(function() {var ga = document.createElement("script");ga.type = "text/javascript";ga.async = true;ga.src = "/sites/all/files/googleanalytics/ga.js?b";var s = document.getElementsByTagName("script")[0];s.parentNode.insertBefore(ga, s);})();
//--><!]]>
</script>
    <!-- Start Quantcast tag -->
		  <script type="text/javascript">
		    _qoptions={
		      qacct:"p-a15Hs4ofKGnVw"
		    };
		  </script>
		  <script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>
		  <noscript>
		    <img src="http://pixel.quantserve.com/pixel/p-a15Hs4ofKGnVw.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
		  </noscript>
		  <!-- End Quantcast tag -->  </body>
</html>