<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
  <head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title>Eddie Carter, Rantoul&#039;s first black police officer, longtime game official, remembered | Rantoul Press</title>
    <meta http-equiv="content-language" content="en" />
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script>
<script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
<link rel="image_src" href="http://www.rantoulpress.com/sites/all/files/imagecache/300x300_width_height_scale/images/2017/02/24/Carter-for-rotator-Feb.-22.gif" />
<link rel="shortcut icon" href="http://www.rantoulpress.com/sites/all/files/favicon.ico" type="image/x-icon" />
<meta name="keywords" content="Champaign,Urbana,Danville,Paxton,Rantoul,Mahomet,Monticello,Tuscola,East Central Illinois,University of Illinois at Urbana-Champaign,News" />
<meta name="copyright" content="Copyright (c) 2015 The News-Gazette, Inc." />
<meta name="description" content="RANTOUL — As a high school game official and a policeman, Eddie Carter was known to many as someone who enforced the rules. But more than that, he was a good man, according to those who knew him best.Rantoul’s first black police officer was “a super human being,” retired Police Chief Allen Jones Sr. said." />
    <link type="text/css" rel="stylesheet" media="all" href="http://www.rantoulpress.com/sites/all/modules/custom/custom_node/custom_node.css?G" />
<link type="text/css" rel="stylesheet" media="all" href="http://www.rantoulpress.com/sites/all/modules/custom/custom_blocks/custom_blocks.css?G" />
<link type="text/css" rel="stylesheet" media="all" href="http://www.rantoulpress.com/sites/all/files/css/css_6284497642c332cf12d15e67707c4611.css" />
<link type="text/css" rel="stylesheet" media="screen,projection" href="http://www.rantoulpress.com/sites/all/files/css/css_f3cd191307c9e10db37ec248d3892c8f.css" />
<link type="text/css" rel="stylesheet" media="print" href="http://www.rantoulpress.com/sites/all/files/css/css_face1e53e3ccec48f1e28c18eaafecf0.css" />
<!--[if lte IE 7]>
        <link type="text/css" rel="stylesheet" href="/sites/all/modules/custom/ng_weather/css/weather_ie7.css" media="all" />
      <![endif]-->        <script type="text/javascript" src="http://www.rantoulpress.com/sites/all/files/js/js_ff3a868dc823985b70dcb4df2c1ef764.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","googleanalytics":{"trackOutgoing":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls|xml|z|zip"},"uc_ajax_cart":{"CALLBACK":"\/uc_ajax_cart\/add\/item","SHOW_CALLBACK":"\/uc_ajax_cart\/show","CART_LINK_CALLBACK":"\/uc_ajax_cart\/addlink","BLOCK_UI":2,"TIMEOUT":2500,"UPDATE_CALLBACK":"\/uc_ajax_cart\/update","UPDATE":0,"CART_VIEW_ON":0,"SHOW_VIEW_CALLBACK":"\/uc_ajax_cart\/show-cart-view","TRACK_CLOSED_STATE":0,"INITIAL_CLOSED_STATE":0,"CART_PANE_EFFECT":0,"CART_PANE_EFFECT_DURATION":200,"HIDE_CART_OPERATIONS":false,"COLLAPSIBLE_CART":0,"CART_OPERATION":"Cart","ADD_TITLE":"Please wait","ADD_MESSAGES":["Adding product to cart..."],"REMOVE_TITLE":"Please wait","REMOVE_MESSAGES":["Removing product from cart..."],"UPDATE_TITLE":"Please wait","UPDATE_MESSAGES":["Updating cart..."]},"ws_fl":{"width":92,"height":"21"},"ws_gpo":{"type":"medium","counter":true},"jPlayer":{"swfPath":"\/sites\/all\/libraries\/jplayer","autoPlay":0}});
//--><!]]>
</script>
    
    <!--this code applies superfish style to the network, network lower, and user options menus-->
    <script type="text/javascript">
      $(document).ready(function() {
        $("#network-menu ul.menu").superfish();
        $("#network-menu-lower ul.menu").superfish();
        $("#user-account ul.menu").superfish();
      });
    </script>
  </head>

  <body id="body-specs">
    <div id="wrapper">
      <div class="nav-bar-wrapper">
       <div id="network-nav-bar">
                    <div id="network-menu">
                          <div id="block-menu-menu-ng-network" class="block block-menu region-odd odd region-count-1 count-1">

  
  <div class="content"><ul class="menu"><li class="expanded first last"><a href="/" title="Our sites">Our Sites</a><ul class="menu"><li class="expanded first"><a href="http://www.news-gazette.com" title="">The News-Gazette</a><ul class="menu"><li class="leaf first"><a href="http://digital.news-gazette.com" title="Digital Services">Digital Services</a></li>
<li class="leaf last"><a href="http://www.news-gazette.com/eedition" title="eEdition">eEdition</a></li>
</ul></li>
<li class="leaf"><a href="http://www.news-gazette.com/sports/illini-sports" title="">IlliniHQ</a></li>
<li class="leaf"><a href="http://www.wdws.com/" title="">NewsTalk 1400 WDWS-AM</a></li>
<li class="leaf"><a href="http://www.whms.com/" title="">Lite Rock 97.5 WHMS</a></li>
<li class="leaf"><a href="http://www.1079wkio.com" title="">107.9 WKIO</a></li>
<li class="expanded"><a href="http://www.news-gazette.com/news-gazette-community-newspapers.html" title="Community News">Community News</a><ul class="menu"><li class="leaf first"><a href="http://www.county-star.com/" title="">County Star</a></li>
<li class="leaf"><a href="http://www.the-independent-news.com/" title="">The Independent News</a></li>
<li class="leaf"><a href="http://www.leaderlandnews.com/" title="">The Leader</a></li>
<li class="leaf"><a href="http://www.leroyfcpress.com/" title="">LeRoy Farmer City Press</a></li>
<li class="leaf"><a href="http://www.mcitizen.com/" title="">Mahomet Citizen</a></li>
<li class="leaf"><a href="http://www.paxtonrecord.net/" title="">Paxton Record</a></li>
<li class="leaf"><a href="http://www.journal-republican.com/" title="">Piatt County Journal-Republican</a></li>
<li class="leaf last"><a href="http://www.rantoulpress.com/" title="">Rantoul Press</a></li>
</ul></li>
<li class="expanded last"><a href="http://www.news-gazette.com/news-gazette-magazines.html" title="">Magazines</a><ul class="menu"><li class="leaf first"><a href="http://www.athomeillinois.com" title="At Home ">At Home </a></li>
<li class="leaf last"><a href="http://www.centralillinoisbusiness.com/" title="">Central Illinois Business</a></li>
</ul></li>
</ul></li>
</ul></div>
  
</div>
           </div><!--close network_menu-->
         
         
         <div id="network-login-area">
                        <div id="nav-bar-text">
                   <ul>
                       <li><a href="/user/login?destination=news/living/2017-02-24/eddie-carter-rantouls-first-black-police-officer-longtime-game-official-remem">LOGIN</a></li>
                       <li><a href="/user/register" title="Create new account.">Create new account</a></li>
					   <li><a href="/user/password" title="Request new password via e-mail.">Login problems?</a></li>
                   </ul>
             </div><!--closes create account-->         </div><!--/network-login-area-->
         
                  
                  
         <div id="header-search-field">
                        <form action="/news/living/2017-02-24/eddie-carter-rantouls-first-black-police-officer-longtime-game-official-remem"  accept-charset="UTF-8" method="post" id="search-theme-form">
<div><div id="search" class="container-inline">
  <div class="form-item" id="edit-search-theme-form-1-wrapper">
 <label for="edit-search-theme-form-1">Search: </label>
 <input type="text" maxlength="128" name="search_theme_form" id="edit-search-theme-form-1" size="15" value="" class="form-text search-theme-form-text-input" />
</div>
<input type="image" name="" value="Search" id=""  class="form-submit" src="http://www.rantoulpress.com/sites/all/modules/custom/search_content/images/mag_glass.gif" alt="Click to search" title="Click to search" />
<a href="#" onclick="return false;"><img class="search-options-arrow" src="/sites/all/modules/custom/search_content/images/down_arrows.gif" /></a><div class="search-options-dropdown"><label>Search in:</label> <div class="form-item" id="edit-content-type-wrapper">
 <select name="content-type" class="form-select" id="edit-content-type" ><option value="" selected="selected">Everything</option></select>
</div>
</div><input type="hidden" name="form_build_id" id="form-1a58ed58f76f289c8bf697a35539869e" value="form-1a58ed58f76f289c8bf697a35539869e"  />
<input type="hidden" name="form_id" id="edit-search-theme-form" value="search_theme_form"  />
</div>

</div></form>
                    </div><!--closes header search field-->
        </div><!--closes nav-bar-->
      </div><!--/nav-bar-wrapper-->
      
      <div id="header"> <!--includes logo and menu-->
        <div id="main-logo">
          <div id="business_directory_search">
                      </div>
          <a href = "/"><img src="http://www.rantoulpress.com/sites/all/themes/custom/cms_desktop/rp_desktop/images/rp_logo.gif" alt = "The Rantoul Press"  /></a>
          <a href = "/"><img id="cn-logo" src="http://www.rantoulpress.com/sites/all/themes/custom/cms_desktop/rp_desktop/images/cn_logo.gif" alt = "The News-Gazette Comunity Newspapers" /></a>
        </div><!--/main-logo--> 
        <div id="site-slogan">
             
        </div>
      </div> <!--closes header-->   
 
      <div class="container">
        <div class="span-24">
          <div id="menu">
                          <!-- Primary || Superfish -->
              <div id="superfish">
                <div id="superfish-inner">
                  <ul class="menu"><li class="leaf first"><a href="/category/news" title="News">News</a></li>
<li class="leaf"><a href="/category/sports" title="Sports">Sports</a></li>
<li class="leaf"><a href="/obituaries" title="Obituaries">Obituaries</a></li>
<li class="leaf"><a href="/category/opinions" title="Opinions">Opinions</a></li>
<li class="expanded"><a href="/classified" title="Classified Ads">Classified Ads</a><ul class="menu"><li class="leaf first last"><a href="/rantoul/fakead" title="">Fake Ad Contest Rules</a></li>
</ul></li>
<li class="leaf"><a href="/multimedia/photogallery" title="">Media</a></li>
<li class="leaf"><a href="/subscribe-rantoul-press.html" title="Subscription Information">Subscribe</a></li>
<li class="leaf"><a href="/rantoul-forms.html" title="Announcement Forms">Forms</a></li>
<li class="leaf"><a href="/calendar" title="Upcoming Events">Events</a></li>
<li class="expanded last"><a href="/contact" title="Contact Us">Contact</a><ul class="menu"><li class="leaf first"><a href="/rantoul-feedback.html" title="Feedback Form">Feedback Form</a></li>
<li class="leaf last"><a href="/contact" title="Contact Us">Contact Us</a></li>
</ul></li>
</ul>                </div><!-- / inner -->
              </div><!-- /primary || superfish -->
                      </div><!--closes menu bar-->
                  </div><!--closes header-->
        
        <div id="content-wrapper" class="span-24"><!--holds center and right col divs together-->
          <!--col class changed to span-16-plus, was span-15, DD-->
          <div id="main-content" 
            class="span-16-plus">
            <div class="breadcrumb"><a href="/">Home</a> » <a href="/category/news">News</a> » <a href="/category/news/living">Living</a></div><h2>Eddie Carter, Rantoul&#039;s first black police officer, longtime game official, remembered</h2>           
                          
  <div id="node-1513726" class="node">
     
        
    
  <span class="submitted"><div class="submitted"><span class="timestamp">Fri, 02/24/2017 - 5:20pm</span> | <span class="authors"><a href="/author/dave-hinton">Dave Hinton</a></span></div></span>
  
      <div class="related-content">
        <div id="related-content-media">
    

      
          <a href="http://www.rantoulpress.com/sites/all/files/imagecache/lightbox_800_600_scale/images/2017/02/24/Carter-for-rotator-Feb.-22.gif" class="imagefield imagefield-jquery-lightbox imagefield-jquery-lightbox-300_width_scale" rel="lightbox" title="The late Eddie Carter clowns around, acting like a judge eating his lunch at the bench at Ford County Courthouse in a photo set up by photographer Lyle Weisman. Mr. Carter died Feb. 19 at age 67. (Provided)&nbsp; (&lt;a href=&quot;/image/2017-02-24/carter-rotator-feb-22.html&quot;&gt;More&lt;/a&gt;)"><img src="http://www.rantoulpress.com/sites/all/files/imagecache/300_width_scale/images/2017/02/24/Carter-for-rotator-Feb.-22.gif" alt="Carter for rotator Feb. 22" title="Carter for rotator Feb. 22"  class="imagecache imagecache-300_width_scale" width="300" height="129" /></a>   
  
              <div><small><strong>Photo by: Provided</strong></small></div>
            <div id="related-content-caption"><small>The late Eddie Carter clowns around, acting like a judge eating his lunch at the bench at Ford County Courthouse in a photo set up by photographer Lyle Weisman. Mr. Carter died Feb. 19 at age 67. (Provided)&nbsp;</small></div>        
      
  	

      <ul id="related-content-slider" class="col-md-12 well">
                <li>
    
      <div class="related-media-type">
      Image    </div>
    <a href="http://www.rantoulpress.com/sites/all/files/imagecache/lightbox_800_600_scale/images/2017/02/24/As-an-official-Feb.-22.gif" class="imagefield imagefield-jquery-lightbox imagefield-jquery-lightbox-150_width_scale" rel="lightbox" title="A big part of the late Eddie Carter’s life was spent wearing the striped shirt of an official. He is seen here during a basketball game. Mr. Carter died Feb. 19 at age 67. (&lt;a href=&quot;/image/2017-02-24/official-feb-22.html&quot;&gt;More&lt;/a&gt;)"><img src="http://www.rantoulpress.com/sites/all/files/imagecache/150_width_scale/images/2017/02/24/As-an-official-Feb.-22.gif" alt="As an official Feb. 22" title="As an official Feb. 22"  class="imagecache imagecache-150_width_scale" width="105" height="150" /></a> 
   
  
  
        </li>
  	

    </ul>
<!--  -->  </div>
                        </div>
    
      <div id="social-media-widgets">
      <a href="http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.rantoulpress.com%2Fnews%2Fliving%2F2017-02-24%2Feddie-carter-rantouls-first-black-police-officer-longtime-game-official-remem&amp;layout=button_count&amp;show_faces=false&amp;action=like&amp;colorscheme=light&amp;width=92&amp;height=21&amp;font=&amp;locale=" title="I Like it" class="service-links-facebook-like" rel="nofollow"><span style="display:none;">Facebook Like</span></a><a href="http://www.rantoulpress.com/news/living/2017-02-24/eddie-carter-rantouls-first-black-police-officer-longtime-game-official-remem" title="Plus it" class="service-links-google-plus-one" rel="nofollow"><span style="display:none;">Google Plus One</span></a><a href="http://twitter.com/share?url=http%3A%2F%2Fwww.rantoulpress.com%2Fnews%2Fliving%2F2017-02-24%2Feddie-carter-rantouls-first-black-police-officer-longtime-game-official-remem&amp;count=horizontal&amp;via=&amp;text=Eddie%20Carter%2C%20Rantoul%27s%20first%20black%20police%20officer%2C%20longtime%20game%20official%2C%20remembered&amp;counturl=http%3A%2F%2Fwww.rantoulpress.com%2Fnews%2Fliving%2F2017-02-24%2Feddie-carter-rantouls-first-black-police-officer-longtime-game-official-remem" class="twitter-share-button service-links-twitter-widget" title="Tweet This" rel="nofollow"><span style="display:none;">Tweet Widget</span></a>    </div>
    
  <div class="content">
    <p>RANTOUL — As a high school game official and a policeman, Eddie Carter was known to many as someone who enforced the rules. But more than that, he was a good man, according to those who knew him best.</p>
<p>Rantoul’s first black police officer was “a super human being,” retired Police Chief Allen Jones Sr. said.</p>
<p>“He dealt with everybody the same way, and people treated him the same,” Jones said.</p>
<p>Jones said he broke down when he heard Mr. Carter had died Sunday, Feb. 19, at age 67. He had lost a close friend.</p>
<p>“I think he was proud of who he was, proud of his family,” Jones said. “Eddie was, first of all, a loving husband, father and police officer. He means a lot to our community.”</p>
<p>Mr. Carter, who retired from police work about 12 years ago, continued to officiate high school contests, whether it was baseball, softball, basketball or volleyball, until about seven years ago when declining health forced him to give up one of the things he loved, said his widow, Margurette.</p>
<p>Mr. Carter underwent a kidney transplant in 2006.</p>
<p>“He had some issues with it. The kidney failed in five years,” Mrs. Carter said, so her husband began dialysis.</p>
<p>“Dialysis is so hard on the body. It does affect the heart,” she said. “He wasn’t sick; he was just tired. He was a good guy, a good guy.”</p>
<p>The couple met while at a bus stop on the first day of school on the campus of Texas College in Tyler, Texas. They were married for 45 years.</p>
<p>A daughter and two grandchildren also survive him.</p>
<p>Mr. Carter joined the Air Force so he wouldn’t be drafted into the Army during the Vietnam War, his widow said, and was first stationed at Ft. Leavenworth prison.</p>
<p>“He worked there. He wasn’t in it,” Margurette Carter said she always tells people.</p>
<p>After less than a year, he was transferred to Chanute Air Force Base in Rantoul, where he completed his four-year military stint in the recreation department, having earned a college degree in physical education in 1971.</p>
<p>It was there that he caught the referee bug. Early on, he met John Heap, who would become a good friend. They would almost always work together officiating games.</p>
<p>“We got along so well, we decided we wanted to work together,” Heap said. “We started out with basketball, then baseball, softball, and when volleyball came along we jumped into that.”</p>
<p>Jones said he always used to kid Carter that he had it easy when officiating volleyball matches. Baseball was a harder job, he said.</p>
<p>Heap and Carter worked so many games together that Heap said whenever he saw coaches, they would ask not only how Heap was doing but also how Carter was getting along.</p>
<p>Heap said the pay wasn’t very good when they first started officiating, but over the years it got better.</p>
<p>“Eddie was a good official,” Heap said. “He had a thorough understanding of the ball games. He knew the rules. He never played favorites.”</p>
<p>The duo frequently worked high school contests three to four times a week.</p>
<p>Heap said once in a while fans would get unruly, but once the game was over, the pair left it at the door. They didn’t dwell on it.</p>
<p>Heap said it won’t be the same without his friend.</p>
<p>“I miss him now that he’s not there to call once in a while. I had a lot of wonderful years working with him,” Heap said.</p>
<p>Needing a job after leaving the Air Force, Mr. Carter got a welcome suggestion from the pastor at Bethany Park Christian Church, where the Carters attended: apply to become a police officer.</p>
<p>Mr. Carter became Rantoul’s first black officer in 1976.</p>
<p>“Ed didn’t go around saying, ‘I’m the first black officer,’” Margurette Carter said. “His role was that of policeman, and that’s how he looked at it. He just did the job.”</p>
<p>He earned an associate degree in law enforcement from Parkland College in 1979 and was named Officer of the Year in 1980 by both the Rantoul Exchange Club and the Knights of Columbus.</p>
<p>Jones, who was Mr. Carter’s field training officer, said they spent eight hours a day together during training and became close friends.</p>
<p>“Eddie and I, when we weren’t talking police business, we’d be talking family We be talking about raising our kids,” Jones said.</p>
<p>He said Mr. Carter knew everyone in town, and everybody knew him. He said Mr. Carter, as recently as two weeks ago, couldn’t go to the grocery store without someone stopping him and saying, “Mr. Carter, how are you?”</p>
<p>Mr. Carter earned a master’s degree in science in counseling from Eastern Illinois University in 1983 and graduated from the FBI National Academy in Quantico, Va.,&nbsp; the following year.</p>
<p>Promoted to lieutenant in 1985, he was commended for updating and restructuring the field training officer program used to train newly hired police officers that year.</p>
<p>Mr. Carter was promoted to deputy chief in February 2000, the first deputy in the Rantoul Police Department. He retired June 3, 2005.</p>
<p>He also received numerous letters of thanks from community members for his work, ranging from finding a missing 8-year-old girl while off duty to being part of the team that solved a string of burglaries.</p>
<p>Mr. Carter and his wife were regular attendees at Rantoul First United Methodist Church.</p>
<p>The Rev. Paula Wallace said the Carters were almost always at the 8 a.m. service.</p>
<p>Having been pastor at the church only a few months, Wallace said she didn’t get to know Mr. Carter very well.</p>
<p>“I felt cheated that I didn’t have more time to get to know him better,” Wallace said.</p>
<p>Margurette Carter said her husband believed in being active in the community, which is something that rubbed off on Hank Gamel, who would also go on to become the police department’s deputy chief.</p>
<p>“He stressed the importance of connecting with people,” Gamel said. “In the late ‘70s and early ‘80s, community relations was the dominant theme.”</p>
<p>Gamel said that’s not an easy thing to do, but Mr. Carter “demonstrated that. I think he practiced what he preached.</p>
<p>“I learned quite a bit from him. He wasn’t always easy, but he was always patient. He was never one to demean a person. He always tried to respect the person, regardless of what they had done. He wasn’t one to look down on people.”</p>
<p>Mr. Carter was a member of Kappa Alpha Psi Fraternity, Fraternal Order of Police, a member of the village revolving loan committee and Community Service Center board, member of Lone Star Lodge No. 18, National Organization of Black Law Enforcement Executives and Champaign/Urbana Officials Association.</p>
<p>Mr. Carter's obituary appears on this website.</p>
<p><a href="mailto:dhinton@rantoulpress.com">dhinton@rantoulpress.com</a><br /><br /><br />&nbsp;</p>
<div class="clear"></div>  </div>
      <div class="links">
      <ul class="links inline"><li class="comment_forbidden first"><span><a href="/user/login?destination=comment%2Freply%2F1513726%23comment-form">Login</a> or <a href="/user/register?destination=comment%2Freply%2F1513726%23comment-form">register</a> to post comments</span></li>
<li class="print_html"><a href="/print/1513726" title="Display a printer-friendly version of this page." class="print-page" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/print/icons/print_icon.gif" alt="Printer-friendly version" title="Printer-friendly version" width="16" height="16" class="print-icon" /></a></li>
<li class="print_mail"><a href="/printmail/1513726" title="Send this page by email." class="print-mail" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/print/icons/mail_icon.gif" alt="Send by email" title="Send by email" width="16" height="16" class="print-icon" /></a></li>
<li class="service-links-facebook"><a href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.rantoulpress.com%2Fnews%2Fliving%2F2017-02-24%2Feddie-carter-rantouls-first-black-police-officer-longtime-game-official-remem&amp;t=Eddie+Carter%2C+Rantoul%27s+first+black+police+officer%2C+longtime+game+official%2C+remembered" title="Share on Facebook." class="service-links-facebook" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/service_links/images/facebook.png" alt="Facebook" title="" width="16" height="16" /></a></li>
<li class="service-links-twitter"><a href="http://twitter.com/share?url=http%3A%2F%2Fwww.rantoulpress.com%2Fnews%2Fliving%2F2017-02-24%2Feddie-carter-rantouls-first-black-police-officer-longtime-game-official-remem&amp;text=Eddie%20Carter%2C%20Rantoul%27s%20first%20black%20police%20officer%2C%20longtime%20game%20official%2C%20remembered" title="Share this on Twitter" class="service-links-twitter" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/service_links/images/twitter.png" alt="Twitter" title="" width="16" height="16" /></a></li>
<li class="service-links-google"><a href="http://www.google.com/bookmarks/mark?op=add&amp;bkmk=http%3A%2F%2Fwww.rantoulpress.com%2Fnews%2Fliving%2F2017-02-24%2Feddie-carter-rantouls-first-black-police-officer-longtime-game-official-remem&amp;title=Eddie+Carter%2C+Rantoul%27s+first+black+police+officer%2C+longtime+game+official%2C+remembered" title="Bookmark this post on Google." class="service-links-google" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/service_links/images/google.png" alt="Google" title="" width="16" height="16" /></a></li>
<li class="service-links-yahoo"><a href="http://bookmarks.yahoo.com/myresults/bookmarklet?u=http%3A%2F%2Fwww.rantoulpress.com%2Fnews%2Fliving%2F2017-02-24%2Feddie-carter-rantouls-first-black-police-officer-longtime-game-official-remem&amp;t=Eddie+Carter%2C+Rantoul%27s+first+black+police+officer%2C+longtime+game+official%2C+remembered" title="Bookmark this post on Yahoo." class="service-links-yahoo" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/service_links/images/yahoo.png" alt="Yahoo" title="" width="16" height="16" /></a></li>
<li class="service-links-stumbleupon"><a href="http://www.stumbleupon.com/submit?url=http%3A%2F%2Fwww.rantoulpress.com%2Fnews%2Fliving%2F2017-02-24%2Feddie-carter-rantouls-first-black-police-officer-longtime-game-official-remem&amp;title=Eddie+Carter%2C+Rantoul%27s+first+black+police+officer%2C+longtime+game+official%2C+remembered" title="Thumb this up at StumbleUpon" class="service-links-stumbleupon" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/service_links/images/stumbleit.png" alt="StumbleUpon" title="" width="16" height="16" /></a></li>
<li class="service-links-reddit"><a href="http://reddit.com/submit?url=http%3A%2F%2Fwww.rantoulpress.com%2Fnews%2Fliving%2F2017-02-24%2Feddie-carter-rantouls-first-black-police-officer-longtime-game-official-remem&amp;title=Eddie+Carter%2C+Rantoul%27s+first+black+police+officer%2C+longtime+game+official%2C+remembered" title="Submit this post on reddit.com." class="service-links-reddit" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/service_links/images/reddit.png" alt="Reddit" title="" width="16" height="16" /></a></li>
<li class="service-links-digg"><a href="http://digg.com/submit?phase=2&amp;url=http%3A%2F%2Fwww.rantoulpress.com%2Fnews%2Fliving%2F2017-02-24%2Feddie-carter-rantouls-first-black-police-officer-longtime-game-official-remem&amp;title=Eddie+Carter%2C+Rantoul%27s+first+black+police+officer%2C+longtime+game+official%2C+remembered" title="Digg this post on digg.com" class="service-links-digg" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/service_links/images/digg.png" alt="Digg" title="" width="16" height="16" /></a></li>
<li class="service-links-delicious last"><a href="http://del.icio.us/post?url=http%3A%2F%2Fwww.rantoulpress.com%2Fnews%2Fliving%2F2017-02-24%2Feddie-carter-rantouls-first-black-police-officer-longtime-game-official-remem&amp;title=Eddie+Carter%2C+Rantoul%27s+first+black+police+officer%2C+longtime+game+official%2C+remembered" title="Bookmark this post on del.icio.us." class="service-links-delicious" rel="nofollow"><img src="http://www.rantoulpress.com/sites/all/modules/contrib/service_links/images/delicious.png" alt="del.icio.us" title="" width="16" height="16" /></a></li>
</ul>    </div>
    <div class="meta">
          <div id="vocab-1513726-1-wrapper" class="vocab-wrapper"><span class="vocab-label">Categories (2):</span><span class="vocab-terms"><a href="/category/news">News</a>, <a href="/category/news/living">Living</a></span></div>      </div>
      <div id="comment-info-wrapper">
      <h3>Comments</h3>
      <p><em>Rantoul Press embraces discussion of both community and world issues. We welcome you to contribute your ideas, opinions and comments, but we ask that you avoid personal attacks, vulgarity and hate speech. we reserve the right to remove any comment at its discretion, and we will block repeat offenders' accounts. To post comments, you must first be a registered user, and your username will appear with any comment you post. Happy posting.</em></p>
    </div>
          <p><a href="/user/login?destination=comment/reply/1513726#comment-form">Login</a> or <a href="/user/register?destination=comment/reply/1513726#comment-form">register</a> to post comments</p>
        </div>
                      </div><!--closes main-content-->
          
          <div id="right-column" class="span-8-minus last">
              <div id="block-custom_blocks-0" class="block block-custom_blocks region-odd even region-count-1 count-6">

  
  <div class="content"><div id ="custom-blocks-dotd">
  <a href="http://www.news-gazette.com/store/deal-day" id="header-link" title="Deal of the Day" target="_blank"></a>  <h4><a href="http://www.news-gazette.com/store/deal-day/recreation/lake-woods-golf-course-180-90.html" target="_blank">Lake of the Woods Golf Course</a></h4>
  <div><a href="http://www.news-gazette.com/store/deal-day/recreation/lake-woods-golf-course-180-90.html" target="_blank">Buy a $180.00 certificate for only $90.00</a></div>
  <div id="stock-warning"></div>
  <div id="business-logo"><a href="http://www.news-gazette.com/store/deal-day/recreation/lake-woods-golf-course-180-90.html" title="Lake of the Woods Golf Course" target="_blank"><img src="http://www.rantoulpress.com/sites/all/files/imagecache/200x125_width_height_scale/businesses/logos/lake_0.jpg" alt="Logo for " title="Logo for "  class="imagecache imagecache-200x125_width_height_scale" width="151" height="85" /></a></div>
  <div class="custom-blocks-dotd-more">
        <ul>
          </ul>
    <!--<div class="center"><small>()</small></div>-->
    <!--<h5></h5>-->
    <!--<ul>
      <li></li>
      <li></li>
    </ul>-->
  </div>
</div></div>
  
</div>
<div id="block-block-6" class="block block-block region-even odd region-count-2 count-7">

  
  <div class="content"><!-- /4073248/Weeklies_Featured_MR_ROS --><!-- /4073248/Weeklies_Featured_MR_ROS --><div id='div-gpt-ad-1479763295532-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1479763295532-0'); });
</script></div>
<!-- Rantoul_Press_RunofSite_MR --><!-- Rantoul_Press_RunofSite_MR --><div id='div-gpt-ad-1391718641158-0' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1391718641158-0'); });
</script></div>
</div>
  
</div>
          </div>   
        </div><!--closes content-wrapper-->
        <div id="feeder">
                  </div>
      </div><!--closes container-->
    </div><!-- closes wrapper -->
    
    <div class="nav-bar-wrapper">
      <div id="network-nav-bar-lower">
                  <div id="network-menu-lower">
                        <div id="block-menu-menu-menu-network-menu-lower" class="block block-menu region-odd even region-count-1 count-4">

  
  <div class="content"><ul class="menu"><li class="expanded first last"><a href="/" title="Our Sites">Our Sites</a><ul class="menu"><li class="expanded first"><a href="http://www.news-gazette.com/" title="News-Gazette">News-Gazette</a><ul class="menu"><li class="leaf first"><a href="http://digital.news-gazette.com/" title="Digital Services">Digital Services</a></li>
<li class="leaf last"><a href="http://www.news-gazette.com/eedition" title="e-Edition">e-Edition</a></li>
</ul></li>
<li class="leaf"><a href="http://www.illinihq.com" title="IlliniHQ.com">IlliniHQ</a></li>
<li class="leaf"><a href="http://www.wdws.com" title="NewsTalk 1400 WDWS-AM">NewsTalk 1400 WDWS-AM</a></li>
<li class="leaf"><a href="http://www.whms.com" title="Lite Rock 97.5 WHMS">Lite Rock 97.5 WHMS</a></li>
<li class="leaf"><a href="http://www.1079wkio.com" title="">107.9 WKIO</a></li>
<li class="expanded"><a href="http://www.news-gazette.com/news-gazette-community-newspapers.html" title="Community News">Community News</a><ul class="menu"><li class="leaf first"><a href="http://www.county-star.com" title="County Star">County Star</a></li>
<li class="leaf"><a href="http://www.the-independent-news.com" title="Independent News">Independent News</a></li>
<li class="leaf"><a href="http://www.leaderlandnews.com" title="The Leader">The Leader</a></li>
<li class="leaf"><a href="http://www.leroyfcpress.com/" title="">LeRoy Farmer City Press</a></li>
<li class="leaf"><a href="http://www.mcitizen.com" title="Mahomet Citizen">Mahomet Citizen</a></li>
<li class="leaf"><a href="http://www.paxtonrecord.net" title="Paxton Record">Paxton Record</a></li>
<li class="leaf"><a href="http://www.journal-republican.com" title="Piatt County Journal-Republican">Piatt County Journal-Republican</a></li>
<li class="leaf last"><a href="http://www.rantoulpress.com" title="Rantoul Press">Rantoul Press</a></li>
</ul></li>
<li class="expanded last"><a href="http://www.news-gazette.com/news-gazette-magazines.html" title="Magazines">Magazines</a><ul class="menu"><li class="leaf first"><a href="http://www.athomeillinois.com" title="At Home">At Home </a></li>
<li class="leaf last"><a href="http://www.centralillinoisbusiness.com" title="Central Illinois Business">Central Illinois Business</a></li>
</ul></li>
</ul></li>
</ul></div>
  
</div>
          </div><!--close network_menu-lower-->
                
              </div><!--closes nav-bar-->
    </div><!--/nav-bar-wrapper-->
    
    <div id="footer-area">
              <div id="footer" class="clear">
                      <div id="block-block-16" class="block block-block region-odd odd region-count-1 count-5">

  
  <div class="content"><div class="span-24">Contents of this site are <a href="/section/services/reader-services/copyright.html">Copyright © 2015 Rantoul Press</a>. All rights reserved.<br /><a href="/sitemap/">Sitemap</a> | <a href="/section/services/online-services/news-gazette-online-privacy-policy.html">Privacy Policy</a> | <a href="/section/services/online-services/terms-use.html">Terms of Use</a> | <a href="/contact/">Contact Us</a> | <a href="/our-clients">Our Clients</a></div>
<div class="span-24"><a href="http://digital.news-gazette.com/web-design-development" target="_blank"><img alt=" Web Design/Development Champaign-Urbana" src="/sites/all/themes/custom/cms_960_desktop/images/digital_services_logo.png" /></a></div>
</div>
  
</div>
                            </div>
          </div><!--closes footer area-->
    <script type="text/javascript">
<!--//--><![CDATA[//><!--
var _gaq = _gaq || [];_gaq.push(["_setAccount", "UA-4954131-30"]);_gaq.push(["_trackPageview"]);(function() {var ga = document.createElement("script");ga.type = "text/javascript";ga.async = true;ga.src = "/sites/all/files/googleanalytics/ga.js?G";var s = document.getElementsByTagName("script")[0];s.parentNode.insertBefore(ga, s);})();
//--><!]]>
</script>
    <!-- Start Quantcast tag -->
		  <script type="text/javascript">
		    _qoptions={
		      qacct:"p-a15Hs4ofKGnVw"
		    };
		  </script>
		  <script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>
		  <noscript>
		    <img src="http://pixel.quantserve.com/pixel/p-a15Hs4ofKGnVw.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
		  </noscript>
		  <!-- End Quantcast tag -->  </body>
</html>